Opened 3 years ago

Closed 3 years ago

#19957 closed Uncategorized (worksforme)

Can't use pip to install Django 1.5 when using python 2.6

Reported by: mbucknell@… Owned by: nobody
Component: Uncategorized Version: 1.5
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


I have tried to use pip to install Django 1.5 on a virtualenv with python 2.6. I get a message:
Downloading/unpacking Django==1.5

Could not find a version that satisfies the requirement Django==1.5 (from versions: )

No distributions matching the version for Django==1.5

I have attached the log file.

Note that it does work if I am using a virtualenv with python 2.7. However our deployment environment only has 2.6

Change History (2)

comment:1 Changed 3 years ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Isn't that a bug of pip/virtualenv rather than a bug of Django?

comment:2 Changed 3 years ago by carljm

  • Resolution set to worksforme
  • Status changed from new to closed

It would be a pip bug if it were a bug, but installing Django==1.5 via pip from a Python 2.6 virtualenv works fine here. I would guess there's something else unusual going on on that deployment environment.

Note: See TracTickets for help on using tickets.
Back to Top