Opened 3 years ago

Closed 3 years ago

#19936 closed Bug (duplicate)

Django 1.4 Docs broken link to sourcecode live on github

Reported by: sethwoodworth Owned by: nobody
Component: Documentation Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

In the master 1.5 branch of django on github, the modeltests directory was broken up into multiple directories. In the docs on complex lookups with q objects there is a link to this test:

https://code.djangoproject.com/browser/django/trunk/tests/modeltests/or_lookups/tests.py

This redirects to the github url:

https://github.com/django/django/tree/master/tests/modeltests/or_lookups/tests.py

The updated link for django version 1.4.5 is:

https://github.com/django/django/blob/1.4.5/tests/modeltests/or_lookups/tests.py

I am not sure how to update this link to keep the code.djangoproject.com url.

Change History (2)

comment:1 Changed 3 years ago by sethwoodworth

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

The url https://github.com/django/django/blob/stable/1.4.x/tests/modeltests/or_lookups/tests.py uses branches instead of tags to get to the same test url, and wont break when/if 1.4.6 is released.

comment:2 Changed 3 years ago by claudep

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19926

Note: See TracTickets for help on using tickets.
Back to Top