Opened 4 years ago

Closed 4 years ago

#19916 closed Bug (fixed)

contrib.comments's templatetags use token.contents.split()

Reported by: Baptiste Mispelon Owned by: Baptiste Mispelon
Component: contrib.comments Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by Aymeric Augustin)

This is the same bug as #19882, but for the template tags of contrib.comments.

It's caused by using token.contents.split() instead of token.split_contents(), causing problems when a variable has a filter with an argument that contains spaces.

Change History (5)

comment:1 Changed 4 years ago by Carl Meyer

Triage Stage: UnreviewedAccepted

comment:2 Changed 4 years ago by Aymeric Augustin

Description: modified (diff)

comment:3 Changed 4 years ago by Baptiste Mispelon

Has patch: set
Status: newassigned

comment:4 Changed 4 years ago by Aymeric Augustin

Triage Stage: AcceptedReady for checkin

[rhetorical question] Do we really need that many tests to test such a trivial change?

comment:5 Changed 4 years ago by Claude Paroz

Resolution: fixed
Status: assignedclosed

Pull request merged in 81804ae474d6fe5d3ab9348cfe86ee3779473a2a (Fix 19916. Smarter tokenizing of contrib.comment's templatetags arguments. )

Note: See TracTickets for help on using tickets.
Back to Top