Code

#19859 closed Uncategorized (duplicate)

Django 1.4.4 release tarball includes .pyc files (including bare)

Reported by: katzj@… Owned by: nobody
Component: Uncategorized Version: 1.4
Severity: Release blocker Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The Django 1.4.4 release tarball includes some .pyc files

$ tar -tzf Django-1.4.4.tar.gz |grep \.pyc
Django-1.4.4/django/conf/locale/init.pyc
Django-1.4.4/django/conf/locale/en/init.pyc
Django-1.4.4/django/conf/locale/en/formats.pyc
Django-1.4.4/django/contrib/sessions/management/init.pyc

Not great in general but the last one is especially bad as there isn't a corresponding .py file of init.py and django.contrib.sessions.management doesn't exist for 1.4. This breaks usage on OS/python versions that don't match (eg, CentOS6 + python 2.6 breaks for me)

Attachments (0)

Change History (2)

comment:1 Changed 14 months ago by toofishes

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Duplicate of #19858, it appears.

comment:2 Changed 14 months ago by Jeremy Katz <katzj@…>

  • Resolution set to duplicate
  • Status changed from new to closed

Ah, yes. Apparently I'm not the only person upgrading tonight.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.