Opened 3 years ago

Closed 3 years ago

#19853 closed Cleanup/optimization (duplicate)

EmailField default max_length led to errors

Reported by: arnaud@… Owned by: nobody
Component: contrib.auth Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no



I'm currently running a web application with Django 1.4.3 using django.contrib.auth app for users registration and django social auth to work with Facebook connect.

Since few days, I got errors when some users are registering because their email adress is more than the 75 default characters of the built-in EmailField.
After some research, I found this RFC ( which say that an email can be up to 256 characters (64 for the local part and the rest for the domain).

These users are registered but the email field is empty..

Does the default max_length for the User model or EmailField should be updated?

Thanks for your help.

Change History (1)

comment:1 Changed 3 years ago by timo

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #11365

Note: See TracTickets for help on using tickets.
Back to Top