Code

#19832 closed Bug (duplicate)

DecimalField validation shoud use plural forms

Reported by: clay.evil@… Owned by: nobody
Component: Forms Version: 1.4
Severity: Normal Keywords: DecimalField validation
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The django.forms.fields.DecimalField line 260 - shlud use plural forms for decimal places and digis errors. Thank you.

Attachments (0)

Change History (3)

comment:1 Changed 17 months ago by claudep

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

I guess you are targeting those strings:

    'max_digits': _('Ensure that there are no more than %s digits in total.'),
    'max_decimal_places': _('Ensure that there are no more than %s decimal places.'),
    'max_whole_digits': _('Ensure that there are no more than %s digits before the decimal point.')

#17840 is related.

comment:2 Changed 17 months ago by clay.evil@…

Yes, I know its annoying, but devil is in the detail, and since Django uses plural forms in many parts, this will add to Django's perfection.
I'm very happy that i can use Django, you have done a very very good & great & marvelous job. Thank you all. I'm coding right now, so i just felt the need to thank you.

comment:3 Changed 17 months ago by claudep

  • Resolution set to duplicate
  • Status changed from new to closed

The patch of ticket #17840 now includes the ungettext_lazy calls. Closing as duplicate of that ticket.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.