Code

Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#19805 closed Bug (duplicate)

Required trailing slash on tarball URLs breaks pip

Reported by: jaylett Owned by: nobody
Component: *.djangoproject.com Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

https://www.djangoproject.com/download/1.4.3/tarball/ ends in a slash. Without a slash, the URL returns 404 rather than the redirect to the actual tarball. Unfortunately, pip seems to remove the trailing slash before fetching the URL. (I haven't upgrade pip from my distro version—this is on Ubuntu 12.10—and it definitely worked as little as a few weeks ago.) Manually resolving the redirect yields a URL that pip handles quite happily.

user@ubuntu:~$ virtualenv --system-site-packages ENV
user@ubuntu:~$ ENV/bin/pip --version
pip 1.1 from /home/user/ENV/lib/python2.7/site-packages/pip-1.1-py2.7.egg (python 2.7)
user@ubuntu:~$ ENV/bin/pip install https://www.djangoproject.com/download/1.4.3/tarball/
Downloading/unpacking https://www.djangoproject.com/download/1.4.3/tarball
  HTTP error 404 while getting https://www.djangoproject.com/download/1.4.3/tarball
  Could not install requirement https://www.djangoproject.com/download/1.4.3/tarball because of error HTTP Error 404: NOT FOUND
Could not install requirement https://www.djangoproject.com/download/1.4.3/tarball because of HTTP error HTTP Error 404: NOT FOUND for URL https://www.djangoproject.com/download/1.4.3/tarball
Storing complete log in /home/user/.pip/pip.log
user@ubuntu:~$ ENV/bin/pip install http://www.djangoproject.com/m/releases/1.4/Django-1.4.3.tar.gz
Downloading/unpacking http://www.djangoproject.com/m/releases/1.4/Django-1.4.3.tar.gz
  Downloading Django-1.4.3.tar.gz (7.7Mb): 7.7Mb downloaded
  Running setup.py egg_info for package from http://www.djangoproject.com/m/releases/1.4/Django-1.4.3.tar.gz

etc

Attachments (0)

Change History (2)

comment:1 Changed 14 months ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #19772.

I've deployed the patch on the server while we're waiting for 1.5rc2. Does it work for you now?

Is there any particular reason to use the tarball URL rather than pip install Django==1.4.3?

comment:2 Changed 14 months ago by jaylett

Works fine. As in the duplicate ticket, I was actually using the URL for the 1.5rc, but for some reason I didn't use that in my bug report. (Possibly I assumed it would disappear at 1.5 final?)

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.