Code

#19696 closed Bug (duplicate)

Collectstatic management command: unicodeerror

Reported by: arn.breton@… Owned by: nobody
Component: contrib.staticfiles Version: 1.4
Severity: Normal Keywords: unicodeerror, collectstatic, css, assets
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Hi,

I experienced an issue today while using the collectstatic command.

One of my CSS files contains some comments with accent marks (I'm french).
When the command passes on this file, it crashes with a standard unicodeerror ("character not in range").

The error occured here: https://github.com/django/django/blob/master/django/contrib/staticfiles/storage.py#L226

When I deleted these comments, it works again.

Attachments (0)

Change History (2)

comment:1 Changed 15 months ago by claudep

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

This looks like #18430, which is fixed in Django 1.5. Could you try if it still crashes with 1.5?

comment:2 Changed 15 months ago by claudep

  • Resolution set to duplicate
  • Status changed from new to closed

Reopen if you can reproduce with recent code.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.