Code

#19623 closed Uncategorized (duplicate)

Update inlines.js to use jQuery 1.9

Reported by: jordanorc Owned by: nobody
Component: contrib.admin Version: 1.4
Severity: Normal Keywords: jquery admin inlines.js
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

On line 44 in inlines.js, we have the code:

$(this).attr("tagName") == "TR"

In jQuery version 1.9, this code doesn't works.

Is better to do:

$(this).is("tr")

So, it works on jQuery 1.4.2 and jQuery 1.9

Attachments (1)

inlines.diff (3.8 KB) - added by jordanorc 15 months ago.
Patch to solve the problem

Download all attachments as: .zip

Change History (4)

Changed 15 months ago by jordanorc

Patch to solve the problem

comment:1 Changed 15 months ago by mlavin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

This is more or less the same issue reported in #19598 though this has a patch.

comment:2 Changed 15 months ago by jordanorc

Yes... Is the same bug. Sorry for that. The patch can be attached to issue #19598, if necessary.

comment:3 Changed 15 months ago by bpeschier

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #19598

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.