Opened 2 years ago

Closed 2 years ago

#19613 closed Bug (fixed)

Offline PDF version not available

Reported by: petrovic.milan@… Owned by: aaugustin
Component: *.djangoproject.com Version: master
Severity: Normal Keywords: pdf, 404
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

When trying to download the PDF offline version of the doc's, I get the "404 Not found" error.

Steps to reproduce:

  1. Open the v1.5 doc's home page: https://docs.djangoproject.com/en/1.5/
  2. Click the "PDF" link for offline documentation version: http://media.readthedocs.org/pdf/django/1.5.X/django.pdf

Browser: Mozilla Firefox v18
OS: Ubuntu 12.10, Gnome 3.6

Change History (3)

comment:1 Changed 2 years ago by akaariai

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Same here, the link doesn't work.

1.4 and dev seem to work.

comment:2 Changed 2 years ago by aaugustin

  • Component changed from Documentation to Djangoproject.com Web site
  • Owner changed from nobody to aaugustin
  • Status changed from new to assigned
  • Type changed from Uncategorized to Bug
  • Version changed from 1.5-beta-1 to master

RTD has the 1.4 version under 1.4.X and the 1.5 version under 1.5.x (lowercase). I thinks that's because 1.4.X was the last branch created on SVN, and 1.5.x the first branch created on git.

The docs site template contains <a href="http://media.readthedocs.org/pdf/django/{{ version }}.X/django.pdf">PDF</a>, which works for 1.4 but not for 1.5.

comment:3 Changed 2 years ago by Aymeric Augustin <aymeric.augustin@…>

  • Resolution set to fixed
  • Status changed from assigned to closed

In 5f17ee1c431cc6d8d3d6d7c387d80b7328c6114d/djangoproject.com:

Fixed #19613 -- Link to PDF version of the docs.

Note: See TracTickets for help on using tickets.
Back to Top