Opened 3 years ago

Closed 3 years ago

#19599 closed Uncategorized (duplicate)

incorrect instructions for configuration of Apache's WSGIPythonPath setting.

Reported by: anonymous Owned by: nobody
Component: Documentation Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


The documentation for how to use Django with Apache and mod_wsgi tells us:

edit your Apache server’s httpd.conf file and add:

WSGIScriptAlias / /path/to/
WSGIPythonPath /path/to/

It then tells us that if using a virtualenv:

you'll need to add the path to this virtualenv's site-packages directory to your Python path as well. To do this, you can add another line to your Apache configuration:

WSGIPythonPath /path/to/your/venv/lib/python2.X/site-packages

The problem is that Apache only honors the last WSGIPythonPath it encounters, so the first one is ignored.

This problem was encountered while using Apache 2.2.23.

Change History (1)

comment:1 Changed 3 years ago by claudep

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19042.

For this sort of information, I'd suggest reading the latest version of the docs.

Note: See TracTickets for help on using tickets.
Back to Top