Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#19558 closed Uncategorized (invalid)

Writing your first Django app, part 1 error

Reported by: ranamalo Owned by: nobody
Component: Documentation Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


I had to add the following to my in order to run syncdb:

import os
os.environ['LANG'] = 'en_US.UTF-8'

Change History (3)

comment:1 Changed 3 years ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to needsinfo
  • Status changed from new to closed

Configuring the locale in application code isn't necessary in general. The tutorial works for me without this, and I've run Django in a variety of environment without needing it.

Since you didn't provide any information on what happened before you added this to your settings, I cannot analyze anything, let alone identify a bug in Django.

All I can say is that locale belongs in system configuration rather than in application code.

I suggest using Django's support channels, and if necessary, to reopen this ticket with more information — at least the full traceback and the output of locale.

comment:2 Changed 3 years ago by ranamalo

Sorry I did something wrong. Not a bug.

comment:3 Changed 3 years ago by claudep

  • Resolution changed from needsinfo to invalid
Note: See TracTickets for help on using tickets.
Back to Top