Opened 3 years ago

Closed 3 years ago

#19369 closed New feature (duplicate)

add/remove on M2M relations with intermediary model

Reported by: ktosiek Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


At the moment add and remove methods are not added to ManyRelatedManager if the intermediary model was not auto-created. I think they should be added as long as all fields (except the 2 obvious foreign keys :-)) are optional (that is, have null=True or default). Is there any way to identify such models already in Django?

This would be especially helpful when adding intermediary model to already existing m2m fields.

Change History (1)

comment:1 Changed 3 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9475.

Note: See TracTickets for help on using tickets.
Back to Top