Opened 4 years ago

Closed 4 years ago

#19365 closed Bug (wontfix)

Create a `NonNegativeIntegerField` alias for `PositiveIntegerField`

Reported by: Alex Owned by: nobody
Component: Database layer (models, ORM) Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no


The current name is totally bogus, we should at least have an alias that's correct.

Change History (3)

comment:1 Changed 4 years ago by charettes

What about naming the alias UnsignedIntegerField.

comment:2 Changed 4 years ago by ramiro

  • Has patch set

I've started a branch using the name proposed by charettes:

I wonder how changes like this interact with South migrations and if there is something we need to to differently. Opinions and hints welcome.

Last edited 4 years ago by ramiro (previous) (diff)

comment:3 Changed 4 years ago by jacob

  • Resolution set to wontfix
  • Status changed from new to closed

I'm -1 on this change: "there should be one -- and preferably only one -- way to do it." I don't see the need to have multiple names for the same field. Yes, the name isn't perfect, but it's fine.

Note: See TracTickets for help on using tickets.
Back to Top