Code

#19336 closed Bug (duplicate)

AttributeError when using GeoValuesListQuerySet as a subquery

Reported by: nosa_manuel Owned by: nobody
Component: GIS Version: 1.3
Severity: Normal Keywords: gis orm
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

At some point the compiler tries to compare the PostGIS adapter argument to a string and you get:

AttributeError: 'str' object has no attribute 'ewkb'

To reproduce:

pks = Point.objects.filter(point__intersects=some_geometry).values_list('object_id', flat=True))
objects = Object.objects.filter(pk__in=campus_pks)

Attachments (0)

Change History (1)

comment:1 Changed 17 months ago by claudep

  • Component changed from Uncategorized to GIS
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Seems a duplicate of #14483

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.