Code

#19281 closed Uncategorized (duplicate)

Modules to import in documentation

Reported by: krister.svanlund@… Owned by: nobody
Component: Documentation Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The django documentation is very useful in a lot of ways but in my opinion there is a problem when using it for reference. The module an object belongs to is not printed out anywhere near it (except in some cases where it is mentioned in the description). This makes it much harder than it should have to be to use the django manual for reference. Today I learned that the module is actually written out in the permalink for the object so the data is apparently available when generating the docs.

My suggestion is that the documentation is changed so that objects mentioned also clearly shows which module it belongs to without requiring hovering and mentally parsing url. An alternative solution would be to print this information in the beginning of a page on a form similar to "The following objects belong to the module xxx.xxx.xxx if not otherwise specified." I see the later suggestion as less satisfactory, both due to it being printed separate from the actual object of interest and that I believe it would take a lot more work to implement.

Attachments (0)

Change History (1)

comment:1 Changed 17 months ago by timo

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the feedback, this looks like a duplicate of #15396.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.