Code

#19249 closed Uncategorized (duplicate)

SECURE_PROXY_SSL_HEADER Example in Documentation Should Use X-Forwarded-Proto Instead of X-Forwarded-Protocol

Reported by: fred.palmer@… Owned by: nobody
Component: Documentation Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

While setting up a reverse proxy scenario with nginx and AWS I noticed the documentation uses an example (while technically correct) is somewhat off-kilter from emerging de-facto standards for the header in question.

For example - the Elastic Load Balancer uses:

http://docs.amazonwebservices.com/ElasticLoadBalancing/latest/DeveloperGuide/arch-loadbalancing.html#x-forwarded-proto

There is also a wikipedia article mentioning the same thing (albeit not the bible):
http://en.wikipedia.org/wiki/List_of_HTTP_header_fields

I would like to see the documentation perhaps reflect the state of things most common in the working world if possible.

Attachments (0)

Change History (1)

comment:1 Changed 18 months ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19428

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.