Code

#19111 closed Uncategorized (duplicate)

CachedFilesMixin Shouldn't Fail on Missing Files

Reported by: matthewwithanm Owned by: nobody
Component: contrib.staticfiles Version: 1.4
Severity: Normal Keywords: staticfiles
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

I appreciate the reasoning for the ValueError in hashed_name(), but I think they should be suppressed (converted to warnings) in the post_process() loop. A single bad URL shouldn't prevent you from collecting your other static files—especially when it may occur in a third party app.

Attachments (0)

Change History (2)

comment:1 Changed 20 months ago by aaugustin

  • Component changed from File uploads/storage to contrib.staticfiles
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Duplicate of #18958.

comment:2 Changed 20 months ago by aaugustin

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.