Opened 3 years ago

Closed 3 years ago

#19063 closed Bug (fixed)

gml(version=3) does not work for PostGIS

Reported by: lmisek@… Owned by: nobody
Component: GIS Version: master
Severity: Normal Keywords: postgis gml
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no


using function gml() with version=3 does not work for PostGIS.
Instead version=2 is always used.

The problem is in /trunk/django/contrib/gis/db/models/
def gml(self, precision=8, version=2, **kwargs):

parameter procedure_fmt is correctly prepared but not passed to _spatial_attribute function

It seems that
s['procedure_fmt'] = procedure_fmt
is missing

Change History (3)

comment:1 Changed 3 years ago by anonymous

  • Easy pickings set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 3 years ago by claudep

  • Triage Stage changed from Unreviewed to Accepted

comment:3 Changed 3 years ago by Claude Paroz <claude@…>

  • Resolution set to fixed
  • Status changed from new to closed

In d25a599dca9b7644b238f6c89a66545dfdabe393:

Fixed #19063 -- Fixed version parameter of gml GeoQuerySet method

Thanks lmisek@… for the report.

Note: See TracTickets for help on using tickets.
Back to Top