Code

Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#19017 closed Bug (duplicate)

If command is called from code, it does not change locale to previous state

Reported by: andrey@… Owned by: nobody
Component: Core (Management commands) Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Currently code is:

        except CommandError, e:
             if show_traceback:
                 traceback.print_exc()
             else:
                 self.stderr.write(smart_str(self.style.ERROR('Error: %s\n' % e)))
             sys.exit(1)
        if saved_lang is not None:
            translation.activate(saved_lang)

So if command raises exception, translation is not restored

Attachments (1)

mgmt.patch (621 bytes) - added by andrey@… 22 months ago.

Download all attachments as: .zip

Change History (4)

Changed 22 months ago by andrey@…

comment:1 Changed 22 months ago by claudep

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17947 (already fixed). Thanks for the report, but try to look at latest code before submitting ticket and patch, this will save you time!

comment:2 Changed 22 months ago by gugu

Can somebody fix it in 1.4 branch?

comment:3 Changed 22 months ago by claudep

Same response that I gave for #19016, only security or crasher bugs in stable releases, sorry.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.