Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#18971 closed Cleanup/optimization (fixed)

Add a CONTRIBUTING doc

Reported by: kmtracey Owned by: nobody
Component: Documentation Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

https://github.com/blog/1184-contributing-guidelines

Seems this would be helpful to point people in the right direction as to when it's best to open a ticket vs. just opening a pull request.

Change History (7)

comment:1 Changed 3 years ago by Alex

Since we already have an actual document (in a real documentation system), let's just have a CONTRIBUTING file that has a link to the real docs.

comment:2 Changed 3 years ago by Alex

  • Triage Stage changed from Unreviewed to Accepted

comment:3 Changed 3 years ago by ptone

I concur with Alex - I feel the current contributing docs are actually quite good, and we just need to point people there.

I've put together a draft, and verified that there is no problem using an .rst document

https://gist.github.com/3741235

comment:4 Changed 3 years ago by Preston Holmes <preston@…>

  • Resolution set to fixed
  • Status changed from new to closed

In 70248cce0a8a3144df9f36e15fbeb5cc1b091c3e:

Fixed #18971 -- added root level CONTRIBUTING doc

comment:5 Changed 3 years ago by kmtracey

  • Resolution fixed deleted
  • Status changed from closed to reopened

This isn't showing up on github as described in the referenced github blog entry. That entry only mentions the names CONTRIBUTING and CONTRIBUTING.md, ours is CONTRIBUTING.rst, possibly that is the problem?

comment:6 Changed 3 years ago by ptone

  • Resolution set to fixed
  • Status changed from reopened to closed

I had tested this with one of my other repos before pushing and .rst isn't the issue - after another quick experiment - it looks like the issue is that you need the contributing doc in the branch from where you are opening the pull request. I'd say that is a bit of a shortcoming of the github feature, but not in our control.

If you git cherry-pick 70248cce0a8a3144df9f36e15fbeb5cc1b091c3e from your branch (assuming your master is current), push the branch, then attempt to open the pull request, you'll see the banner, the link is to the version of the doc in your fork, another reason it is nice to refer to our published docs - because they can be current even if the fork was stale.

comment:7 Changed 3 years ago by kmtracey

Ah. Thanks for the explanation...

Note: See TracTickets for help on using tickets.
Back to Top