Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#18938 closed Bug (duplicate)

db connection

Reported by: joao_canteiro@… Owned by: nobody
Component: Uncategorized Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Installed Ubuntu 12.4.1 with Xampp

default localhost is not the same as 127.0.0.1

Error: (2002, "Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)")

fixed bug by entering the local IP to replace localhost default value:

" 'HOST': '127.0.0.1', # Set to empty string for localhost. Not used with sqlite3. "

Consider fixing bug or update manual for compatibility issues

Change History (4)

comment:1 Changed 2 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 2 years ago by aaugustin

MySQL uses a local (ie. filesystem) socket when the host is "localhost", using "127.0.0.1" forces the use of a network socket.

This only makes a difference when the server is misconfigured, which appears to be the case here.

I'm nowhere near a MySQL expert, and I'm not sure to understand your request, so I don't know what to do next.

comment:3 Changed 2 years ago by claudep

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9920 (fixed recently), reopen if I misunderstood.

comment:4 Changed 2 years ago by anonymous

Not a request just pointing out that this might happen.

I'm not an expert also, but i think is something worth mention in any place, because may help some one to understand what is a mysql misconfiguration and how to fix it.

If some one know how to fix this issue please point it out.

Note: See TracTickets for help on using tickets.
Back to Top