Opened 4 years ago

Closed 17 months ago

#18889 closed New feature (duplicate)

Provide a simple way to retain parent instances after children are deleted

Reported by: anonymous Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Normal Keywords:
Cc:…, charette.s@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


I have a Location table with two children (using table-inheritance): Restaurant and ChipShop. There should be a simple way to convert a ChipShop to a Restaurant without deleting/recreating the Location which may be referenced by lots of foreign keys, e.g:

location = Location.objects.get(1) # Currently a ChipShop
restaurant = Restaurant(location_ptr=location)
location.chipshop.delete() # Deletes the ChipShop row but not the Location

Currently this can be achieved by using raw sql to bypass django's code that deletes the parent when a child is deleted. Doing the following does not work as the parent is still deleted, perhaps this is a bug?

class ChipShop(Location);
   location_ptr = models.OneToOneField(Location, on_delete=DO_NOTHING, parent_link=True)

Modifying the on_delete of the created location_ptr does nothing as well. Perhaps a setting in the parents Meta that could be used to specify that the parent should not be deleted when the child is?

Change History (5)

comment:1 Changed 4 years ago by anonymous

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset

comment:2 Changed 4 years ago by Ionel Cristian Maries

Cc:… added

comment:3 Changed 4 years ago by Anssi Kääriäinen

Triage Stage: UnreviewedAccepted

I do think having some way to do this would be good. At least I have had need to do obj.delete(delete_parents=False). Not sure if that is the best API...

comment:4 Changed 4 years ago by Simon Charette

Cc: charette.s@… added
Version: 1.4master

comment:5 Changed 17 months ago by Tim Graham

Resolution: duplicate
Status: newclosed

Duplicate of #15579 which has been fixed.

Note: See TracTickets for help on using tickets.
Back to Top