Opened 3 years ago

Closed 3 years ago

#18831 closed Bug (fixed)

Test failures with PostGIS

Reported by: aaugustin Owned by: nobody
Component: GIS Version: master
Severity: Release blocker Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Running the GIS tests with the PostGIS backend gives this result:

======================================================================
FAIL: test_json (django.contrib.gis.geos.tests.test_geos.GEOSTest)
Testing GeoJSON input/output (via GDAL).
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/aaugustin/Documents/dev/django-trunk/django/contrib/gis/geos/tests/test_geos.py", line 207, in test_json
    self.assertEqual(g.json, geom.json)
AssertionError: u'{ "type": "Point", "coordinates": [ 100.000000, 0.000000 ] }' != '{ "type": "Point", "coordinates": [ 100.0, 0.0 ] }'

======================================================================
FAIL: test05_geometries (django.contrib.gis.gdal.tests.test_ds.DataSourceTest)
Testing Geometries from Data Source Features.
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/aaugustin/Documents/dev/django-trunk/django/contrib/gis/gdal/tests/test_ds.py", line 184, in test05_geometries
    self.assertEqual(source.srs_wkt, g.srs.wkt)
AssertionError: 'GEOGCS["GCS_WGS_1984",DATUM["WGS_1984",SPHEROID["WGS_1984",6378137,298.257223563]],PRIMEM["Greenwich",0],UNIT["Degree",0.017453292519943295]]' != 'GEOGCS["GCS_WGS_1984",DATUM["WGS_1984",SPHEROID["WGS_84",6378137,298.257223563]],PRIMEM["Greenwich",0],UNIT["Degree",0.017453292519943295]]'

======================================================================
FAIL: test01e_json (django.contrib.gis.gdal.tests.test_geom.OGRGeomTest)
Testing GeoJSON input/output.
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/aaugustin/Documents/dev/django-trunk/django/contrib/gis/gdal/tests/test_geom.py", line 114, in test01e_json
    self.assertEqual(g.json, geom.json)
AssertionError: u'{ "type": "Point", "coordinates": [ 100.000000, 0.000000 ] }' != '{ "type": "Point", "coordinates": [ 100.0, 0.0 ] }'

----------------------------------------------------------------------
Ran 172 tests in 1.097s

FAILED (failures=3)

OS X Lion, Python 2.7.2, PostgreSQL 9.1.3, PostGIS 1.5.3, GEOS 3.3.2, PROJ 4.7.0, GDAL 1.9.0.

Change History (1)

comment:1 Changed 3 years ago by claudep

  • Resolution set to fixed
  • Status changed from new to closed

Duplicate of #18795

Note: See TracTickets for help on using tickets.
Back to Top