Code

#18746 closed Bug (duplicate)

Django connection is getting lost intermittently while running application

Reported by: umits2009@… Owned by: nobody
Component: HTTP handling Version: 1.4
Severity: Normal Keywords: django connectivity
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Hi,
I am running my application and when i am clicking on a link to go to next page,it is able to proceed.But majority of the times the connection is getting lost.Because of that the session variables are going out of scope.
The application still continues to run though.
Following are the logs i am getting in the command prompt:
Traceback (most recent call last):

File "C:\Python27\lib\wsgiref\handlers.py", line 86, in run

self.finish_response()

File "C:\Python27\lib\wsgiref\handlers.py", line 127, in finish_response

self.write(data)

File "C:\Python27\lib\wsgiref\handlers.py", line 210, in write

self.send_headers()

File "C:\Python27\lib\wsgiref\handlers.py", line 266, in send_headers

self.send_preamble()

File "C:\Python27\lib\wsgiref\handlers.py", line 189, in send_preamble

self._write('HTTP/%s %s\r\n' % (self.http_version,self.status))

File "C:\Python27\lib\wsgiref\handlers.py", line 387, in _write

self.stdout.write(data)

File "C:\Python27\lib\socket.py", line 322, in write

self.flush()

File "C:\Python27\lib\socket.py", line 301, in flush

self._sock.sendall(view[write_offset:write_offset+buffer_size])

error: [Errno 10054] An existing connection was forcibly closed by the remote ho
st


Exception happened during processing of request from ('127.0.0.1', 64463)
Traceback (most recent call last):

File "C:\Python27\lib\SocketServer.py", line 582, in process_request_thread

self.finish_request(request, client_address)

File "C:\Python27\lib\SocketServer.py", line 323, in finish_request

self.RequestHandlerClass(request, client_address, self)

File "C:\Python27\lib\site-packages\django\core\servers\basehttp.py", line 139

, in init

super(WSGIRequestHandler, self).init(*args, kwargs)

File "C:\Python27\lib\SocketServer.py", line 641, in init

self.finish()

File "C:\Python27\lib\SocketServer.py", line 694, in finish

self.wfile.flush()

File "C:\Python27\lib\socket.py", line 301, in flush

self._sock.sendall(view[write_offset:write_offset+buffer_size])

error: [Errno 10054] An existing connection was forcibly closed by the remote ho
st

Please let me know the solution for this.

Attachments (0)

Change History (2)

comment:1 Changed 21 months ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 21 months ago by ramiro

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15178.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.