Code

Opened 2 years ago

Closed 2 years ago

Last modified 23 months ago

#18723 closed Uncategorized (invalid)

Decoupled urls syntax in docs differs from what works on my platform

Reported by: chris.pagnutti@… Owned by: nobody
Component: Documentation Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

I'm just running through the tutorial and found that at the end of Part 3, where decoupled urls are introduced, I was getting an error which was resolved by removing the single quotes. Like this

<li><a href="{% url polls.views.detail poll.id %}">{{ poll.question }}</a></li>

Maybe this is platform specific? I'm running django on arch linux installed from the official repos.

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

You're following the tutorial for the in-development version of Django, but using an earlier release (probably 1.4).

Please use the documentation for your version of Django.

Duplicate of many other tickets.

comment:2 Changed 23 months ago by Aymeric Augustin <aymeric.augustin@…>

In [4da1d0fd65e01abe013e0d5a9174b81c6bbfa677]:

Added a warning about the {% url %} syntax change

at the point where it bites most beginners.

Refs #18787, #18762, #18756, #18723, #18705, #18689 and several duplicates.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.