Opened 3 years ago

Closed 9 months ago

#18714 closed New feature (fixed)

Add an option to compilemessages to compile fuzzy translations

Reported by: rasca Owned by: bak1an
Component: Core (Management commands) Version: master
Severity: Normal Keywords: compilemessages fuzzy msgfmt
Cc: rasca7@…, antonbaklanov@… Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

msgfmt has an option to compile fuzzy messages: -f or --use-fuzzy. I propose adding this parameter to the compilemessages command.

It would be useful in a project I'm working on where we code in English but the client reviews it in Spanish and we translate the messages for a development deployment (leaving them fuzzy) and once we are ready for shipping a translator checks all the fuzzy messages.

Without this option either the develop deployment stays untranslated or the translator doesn't know which strings are the new ones that he has to check.

Change History (16)

comment:1 Changed 3 years ago by claudep

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 3 years ago by ramiro

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10852.

comment:3 Changed 3 years ago by ramiro

  • Resolution duplicate deleted
  • Status changed from closed to new

Sorry, it seems I'm unable to read today. #10852 was about makemessages and this one is about compilemessages.

comment:4 Changed 2 years ago by bak1an

  • Cc antonbaklanov@… added
  • Owner changed from nobody to bak1an
  • Status changed from new to assigned
  • Version changed from 1.4 to master

comment:5 Changed 2 years ago by bak1an

  • Has patch set

comment:6 Changed 18 months ago by timo

  • Patch needs improvement set

Patch no longer merges cleanly.

comment:7 Changed 18 months ago by bak1an

  • Patch needs improvement unset

comment:8 Changed 16 months ago by flagZ

I could really use this. Any ETA on inclusion?

comment:9 Changed 16 months ago by timo

  • Patch needs improvement set

@flagZ, can you review the patch? It needs to be updated since 1.7 is now feature frozen.

comment:10 Changed 16 months ago by Claude Paroz <claude@…>

In 3a435a057c691bf9d5936766f54c5f9bd01be176:

Set compile messages options as class variable

Refs #18714. Same logic as options for makemessages commands.

comment:11 Changed 16 months ago by Claude Paroz <claude@…>

In 0424c84d541d7b0e23783c33c2db495543e3bd47:

[1.7.x] Set compile messages options as class variable

Refs #18714. Same logic as options for makemessages commands.
Backport of 3a435a057 from master.

comment:12 Changed 16 months ago by claudep

I've just committed a slight improvement (simple enough to warrant 1.7 backport), which allows someone to subclass the command to add complementary options with one line of code (in the same vein as 06efeae598c6dafbe56d2ea323a0dccdd5bf2b8e).

But the patch still makes sense (to be able to specify --fuzzy per command invocation).

comment:13 Changed 11 months ago by bak1an

  • Has patch unset
  • Patch needs improvement unset

working on adapting patch to current master state

comment:14 Changed 9 months ago by bak1an

  • Has patch set

comment:15 Changed 9 months ago by berkerpeksag

  • Triage Stage changed from Accepted to Ready for checkin

PR #3553 LGTM. I've reviewed and tested the patch locally.

comment:16 Changed 9 months ago by Claude Paroz <claude@…>

  • Resolution set to fixed
  • Status changed from assigned to closed

In d63703f1cd373f2a1d52e1947835b44d9565c1e0:

Fixed #18714 -- Added 'fuzzy' compilemessages option

Note: See TracTickets for help on using tickets.
Back to Top