Code

Opened 22 months ago

Closed 22 months ago

Last modified 20 months ago

#18593 closed Bug (duplicate)

Admin change list swallows unrelated AttributeErrors from callable display fields

Reported by: pjdelport Owned by: nobody
Component: contrib.admin Version: 1.4
Severity: Normal Keywords: admin, list_display
Cc: Triage Stage: Design decision needed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

If a callable display field on a model or model admin raises either an AttributeError, the interface currently captures the error, and renders the field as EMPTY_CHANGELIST_VALUE.

This behavior is surprising and confusing when the AttributeError originates in unrelated user code called by the display field: errors like third-party app bugs or missing settings get silenced, and the field's content simply becomes "(None)". There's no hint to a novice about what went wrong, or where to look next.

The code responsible for this is in templatetags/admin_list.py's items_for_result(), around lookup_field(). As far as i can tell, all the valid empty fields cases are covered by results of ObjectDoesNotExist or None, and not AttributeError: a missing attribute specified in list_display normally result in ImproperlyConfigured instead.

If there's no compelling reason to capture AttributeError like this, can it simply be removed from the exception list, and allowed to propagate?

Attachments (0)

Change History (5)

comment:1 Changed 22 months ago by pjdelport

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I added a fix and regression test for this on GitHub: #193.

It turns out the test suite itself contained a latent bug that was being masked by this: the above patch fixes that too.

comment:2 follow-up: Changed 22 months ago by aaugustin

  • Triage Stage changed from Unreviewed to Design decision needed

comment:3 in reply to: ↑ 2 Changed 22 months ago by pjdelport

I found an older ticket for this same bug: #16655.

From the comments, the proposed change was discussed and accepted back then, but needed a test: does this patch resolve that?

comment:4 Changed 22 months ago by aaugustin

  • Resolution set to duplicate
  • Status changed from new to closed

comment:5 Changed 20 months ago by aaugustin

Fixed in [617d077f].

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.