Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#18436 closed New feature (fixed)

Review references to Subversion given github move

Reported by: mjtamlyn Owned by: nobody
Component: Documentation Version:
Severity: Release blocker Keywords: svn, subversion, docs
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

There are a few process-docs (release cycle, contibuting etc) which are still making the assumption that the root repo for django is the svn source. Would be good to go through this and tidy them up.

Change History (6)

comment:1 Changed 3 years ago by mjtamlyn

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Summary changed from Overview references to Subversion given github move to Review references to Subversion given github move

comment:2 Changed 3 years ago by aaugustin

  • Severity changed from Normal to Release blocker
  • Triage Stage changed from Unreviewed to Accepted
  • Type changed from Cleanup/optimization to New feature

Yes. This item is on the TODO list but I don't think we ever created a ticket. Here's what must be done:

comment:3 Changed 3 years ago by Aymeric Augustin <aymeric.augustin@…>

  • Resolution set to fixed
  • Status changed from new to closed

In [90fb6a46485d4f3c70d3864ab0a0e2f619449d31]:

Fixed #18436 -- Updated contributing docs for git.

Most of the credit for this large patch goes to Anssi Kääriäinen.
Many thanks to all the people who contributed to the discussion.

comment:4 Changed 3 years ago by ptone

  • Resolution fixed deleted
  • Status changed from closed to reopened

https://github.com/django/django/commit/90fb6a46485d4f3c70d3864ab0a0e2f619449d31

I jumped to the conclusion that the git commit referenced the wrong ticket number in the commit message, actually I can see they are related - I guess the proper thing in hindsight would have been that this should have been marked a dupe of #18307

Sorry for adding to the confusion.

Last edited 3 years ago by ptone (previous) (diff)

comment:5 Changed 3 years ago by ptone

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:6 Changed 3 years ago by aaugustin

I killed two birds with one stone :)

Note: See TracTickets for help on using tickets.
Back to Top