Opened 5 years ago

Closed 4 years ago

Last modified 3 years ago

#18412 closed Cleanup/optimization (fixed)

Make `inspectdb` regression tests introspect a manageable database

Reported by: Ramiro Morales Owned by: nobody
Component: Testing framework Version: master
Severity: Normal Keywords: inspectdb
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by Ramiro Morales)

Currently, the tests in our test suite direct the inspectdb management command calls to examine the 'default' database that will contain the tables corresponding to all the models of the suite being run (they can be hundreds in the case of the full suite).

This makes creating new test cases for the introspection functionality harder that it should because one needs to peruse a gigantic models.py file.

Maybe we can add a third DB to the DATABASES setting used for our tests and direct/restrict the models in regressiontests/inspectdb/models.py to such DB by using a router?.

Change History (6)

comment:1 Changed 5 years ago by Ramiro Morales

Summary: Make syncdb regression tests to introspect a manageable databaseMake syncdb regression tests introspect a manageable database

comment:2 Changed 5 years ago by Ramiro Morales

Description: modified (diff)
Summary: Make syncdb regression tests introspect a manageable databaseMake `inspectdb` regression tests introspect a manageable database

(s/syncdb/inspectdb/g in ticket summary and description).

comment:3 Changed 4 years ago by Aymeric Augustin

Triage Stage: UnreviewedAccepted

comment:4 Changed 4 years ago by Ramiro Morales

Resolution: fixed
Status: newclosed

comment:5 Changed 3 years ago by jacobwegner@…

I think it would be useful to refactor the table_name_filter as part of the management command...perhaps something like

manage.py inspect db --table_name_starts_with=Audit

or

manage.py inspect db --table_name_starts_with=Audit --table_name_exact=AuditLog

Is this worth considering? If so, I will work on a patch.

If the filter really is only meant for tests and it doesn't seem useful to anyone else to expose it as part of the management command "proper", I'll drop it.

comment:6 Changed 3 years ago by Tim Graham

Jacob, I suggest creating a new ticket rather than commenting on a closed one.

Note: See TracTickets for help on using tickets.
Back to Top