Opened 3 years ago

Closed 14 months ago

#18377 closed Bug (needsinfo)

Django Hanging with older Pylibmc

Reported by: andrew@… Owned by: nobody
Component: Documentation Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I notice this has been reported before on ticket #15655 I've got a bit further on the diagnosis.

Using the Debian Squeeze default Pylibmc which is version 1.1.1 then Django will freeze with no logging whatsoever as to the problem. However upgrading Pylibmc to the latest version 1.3.99 and everything is fine.

It would be good to update the documentation to make it clear that a newer version of Pylibmc is required.

Change History (3)

comment:1 Changed 3 years ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Do you know which version of pylibmc fixed the problem?

If this issue is well documented, we could add a check on the version of pylibmc and refuse to start with a buggy version.

comment:2 Changed 3 years ago by aaugustin

I suppose it's https://github.com/lericson/pylibmc/issues/34, which is a duplicate of https://github.com/lericson/pylibmc/pull/19.

This is the "Fixed GIL issues" item of version 1.2.0. So the requirement would be pylibmc >= 1.2.

I don't know exactly how often the problem happens. Is it systematic under mod_wsgi?

comment:3 Changed 14 months ago by timo

  • Resolution set to needsinfo
  • Status changed from new to closed

Closing as needsinfo since we haven't gotten further clarification about the issue and newer versions of Debian are now available which presumably have a more recent version of pylibmc. If someone would like to provide a patch, please reopen.

Note: See TracTickets for help on using tickets.
Back to Top