Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#1835 closed defect (fixed)

[patch] FilePathField breaks admin model documentation

Reported by: Adam Endicott < > Owned by: adrian
Component: contrib.admin Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If a model has a FilePathField, navigating to the admin documentation for the model throws an exception (KeyError). The cause is a missing entry for FilePathField in the DATA_TYPE_MAPPING dict in django/contrib/admin/views/doc.py

The included patch adds the entry, which fixes the problem.

Attachments (1)

doc.diff (611 bytes) - added by Adam Endicott 9 years ago.

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by Adam Endicott

comment:1 Changed 9 years ago by adrian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [2952].

Note: See TracTickets for help on using tickets.
Back to Top