Code

Opened 2 years ago

Closed 22 months ago

#18209 closed New feature (duplicate)

Add GEOS functions supported by Shapely that GeoDjango lacks

Reported by: slinkp Owned by: nobody
Component: GIS Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

We don't have interpolate() or project() methods. Shapely does:
http://toblerity.github.com/shapely/manual.html#linear-referencing-methods

It can useful to specify position along linear features such as LineStrings and
MultiLineStrings with a 1-dimensional referencing system. Shapely supports linear referencing based on length or distance,
evaluating the distance along a geometric object to the projection of a given point, or the point
at a given distance along the object.

I don't know what else, if anything, Shapely has that we don't have, but I stumbled on not having interpolate today.

Attachments (0)

Change History (1)

comment:1 Changed 22 months ago by claudep

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #11948

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.