Opened 3 years ago

Closed 3 years ago

#18203 closed Cleanup/optimization (duplicate)

after upgrade to Django 1.4 , "startproject" create redundant

Reported by: lvscar@… Owned by: nobody
Component: Core (Management commands) Version: 1.4
Severity: Normal Keywords: upgrade
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


After upgrade from Django 1.3.1 to 1.4 , "startproject" command will create redundant . One in root directory (same to , one in inner directory .

It's highly confusing for 1.4 newcomer.

I think it caused by default project layout change.

May be we need improve 1.4 setup script , do some cleanup before install new project layout template files?

Change History (2)

comment:1 Changed 3 years ago by mattmcc

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Related ticket: #18115

comment:2 Changed 3 years ago by ramiro

  • Resolution set to duplicate
  • Status changed from new to closed

Yes it is a duplicate. Thanks.

Note: See TracTickets for help on using tickets.
Back to Top