Opened 4 years ago

Closed 4 years ago

Last modified 5 months ago

#18149 closed Bug (fixed)

Form.prefix example gives wrong separator between prefix and field name

Reported by: matt@… Owned by: nobody
Component: Documentation Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

The docs for Form.prefix (https://docs.djangoproject.com/en/1.3/ref/forms/api/#prefixes-for-forms) have an example which reports the separator used between prefix and field as '-', when the output I'm getting from print ModelForm(prefix = "thing") is '_', e.g:

<input name="prefix_field_name"> and not the <input name="prefix-field_name"> indicated in the example.

Change History (7)

comment:1 Changed 4 years ago by matt@…

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Resolution: invalid
Status: newclosed

early-morning stupidity, not a bug

comment:2 Changed 3 years ago by Bouke Haarsma <bouke@…>

Resolution: invalidfixed

In c0a2388a1c4ead1afaec98e4ebc953a772ca3849:

Fixed #18149 -- Changed language codes for Chinese

Language codes for Chinese are zh_Hans (Simplified) and zh_Hant (Traditional).
Added support for browsers that still send the deprecated language codes.

Thanks to Olli Wang for the report.

comment:3 Changed 3 years ago by Aymeric Augustin <aymeric.augustin@…>

In 859a20560ebd44d917e564d16f3f5f7091c7d823:

Merge pull request #1868 from Bouke/tickets/18419

Fixed #18149 -- Changed language codes for Chinese

comment:4 Changed 3 years ago by Aymeric Augustin

Whoops, the commit message referenced the wrong ticket. This was the fix for #18419.

comment:5 Changed 21 months ago by Tim Graham <timograham@…>

In f0a1df0b0139a7f5a576dff966210b5d52247650:

Removed deprecated Chinese language codes; refs #18149.

comment:6 Changed 5 months ago by Claude Paroz <claude@…>

In dd73908f:

[1.9.x] Removed deprecated Chinese language codes for contrib apps

Refs #18149.

comment:7 Changed 5 months ago by Claude Paroz <claude@…>

In d9a00ad1:

Removed deprecated Chinese language codes for contrib apps

Refs #18149.

Note: See TracTickets for help on using tickets.
Back to Top