Opened 4 years ago

Closed 4 years ago

#18101 closed Bug (duplicate)

Username doesn't allow backslash

Reported by: honyczek@… Owned by: nobody
Component: contrib.auth Version: 1.4
Severity: Normal Keywords: sspi, remote, user, backend, middleware
Cc: honyczek@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


When its used RemoteUserBackend and RemoteUserMiddleware for authentication against Active Directory (eg. using auth_mod_sspi), User.username contains backslash.

If you try to edit user details in Admin pages they can't be saved because of backslash use restriction. It would be great to remove this restriction.

Change History (1)

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

I'm going to mark this as a duplicate of #3011 -- the root problem here is the validation requirements on auth.User, and in order to satsify everyone, we're going to need to fix the root problem.

The good news is that we've had recent movement on this topic, and a relatively simple solution that has BDFL approval. Hopefully, this means we'll have this fixed for 1.5.

Note: See TracTickets for help on using tickets.
Back to Top