Code

Opened 2 years ago

Closed 2 years ago

#18067 closed Bug (fixed)

Offline docs show up as 1.5

Reported by: support@… Owned by: aaugustin
Component: *.djangoproject.com Version: 1.4
Severity: Normal Keywords: offline docs
Cc: Triage Stage: Ready for checkin
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Django 1.4 documentation at https://www.djangoproject.com/m/docs/django-docs-1.4-en.zip shows up as Django 1.5. Typo or wrong docs?

In other news, I'm the developer of Dash (http://kapeli.com/dash), which is a Mac OS X documentation browser, which also comes with the Django documentation. If you think the app would be useful for Django developers, please include a link to Dash in the offline docs download section, for Mac users.

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by ramiro

  • Component changed from Documentation to Djangoproject.com Web site
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Locally built HTML versions of 1.4 final tag and 1.4.X branch both show correctly 1.4 and I can confirm the referenced offcial download .zip shows 1.5.

comment:2 Changed 2 years ago by aaugustin

  • Easy pickings unset
  • Triage Stage changed from Accepted to Ready for checkin

This seems to be a misconfiguration of Read The Docs. The docs for 1.4 are actually built from trunk (well, from the old trunk, before the migration to GitHub). See django-docs-1.4-en/releases/1.5.html.

Marking RFC since there's nothing the community can do. Only a core developer having the keys to Read The Docs can fix this (and switch to building the docs from GitHub at the same time).

comment:3 Changed 2 years ago by aaugustin

  • Owner changed from nobody to aaugustin

I talked to Eric Holscher about this:

  • RTD was configured to build from the GitHub mirror;
  • that probably broke when we changed the repo;
  • I'll ping him when we have the release branches on GitHub to wipe the project and recreate it properly.

comment:4 Changed 2 years ago by aaugustin

  • Resolution set to fixed
  • Status changed from new to closed

The docs are reconfigured to build from the proper branches on GitHub.

Eric also reconfigured RTD.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.