Code

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#18058 closed Bug (worksforme)

Problem with syncdb in Django 1.4

Reported by: diegocepr@… Owned by: nobody
Component: Uncategorized Version: 1.4
Severity: Normal Keywords: startproject, tutorial
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by claudep)

I am trying to do the tutorial with django 1.4 and I get an error doing 'python manage.py syncdb'. I am using the DATABASES as it is created and I've try to use sqlite3 and mysql backends. I tried it in windows and in unix. Rasult is always the same:

  raise ImproperlyConfigured("settings.DATABASES is improperly configured. "
  django.core.exceptions.ImproperlyConfigured: settings.DATABASES is improperly configured. Please supply the ENGINE value. Check settings documentation for more details.

But settings.py is:

DATABASES = {
    'default': {
        'ENGINE': 'django.db.backends.sqlite3', # Add 'postgresql_psycopg2', 'postgresql', 'mysql', 'sqlite3' or 'oracle'.
        'NAME': 'polls.db',                      # Or path to database file if using sqlite3.
        'USER': '',                      # Not used with sqlite3.
        'PASSWORD': '',                  # Not used with sqlite3.
        'HOST': '',                      # Set to empty string for localhost. Not used with sqlite3.
        'PORT': '',                      # Set to empty string for default. Not used with sqlite3.
    }
}

However I have tried with previous version of Django and it works ok.

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by claudep

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

Please use preview next time to properly format the report.

My guess is that you are not placing the settings.py file in the right place. Please use support channels to get help before reporting a bug.
wiki:TicketClosingReasons/UseSupportChannels

comment:2 Changed 2 years ago by anonymous

  • Keywords startproject, tutorial added
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Type changed from Uncategorized to Bug

This is caused by the "django-admin.py startproject mysite" in the tutorial. For some reason it creates multiple settings.py and urls.py files

comment:3 Changed 2 years ago by ramiro

  • Resolution set to worksforme
  • Status changed from reopened to closed

Please follow the pointers given in:

wiki:TicketClosingReasons/UseSupportChannels

Post some more details like if you had a previous installation of Django before you instaled 1.4 and which method of installation did you use.

comment:4 Changed 2 years ago by aaugustin

Your install of Django is probably messed up — you must have installed 1.4 over 1.3 without removing it first. There's roughly a dozen duplicate tickets about this problem.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.