Opened 9 years ago

Closed 10 months ago

#1805 closed defect (invalid)

'adminmedia' is not a valid tag library

Reported by: stanep@… Owned by: adrian
Component: Documentation Version: master
Severity: critical Keywords: Template library django.templatetags.adminmedia
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Runing latest revison 2864
trying to go through tutorial 2

try to access admin pages
http://localhost:8000/admin/

got this error

TemplateSyntaxError at /admin/
'adminmedia' is not a valid tag library: Template library django.templatetags.adminmedia does not have a variable named 'register'

...
Template error

In template C:\Python23\lib\site-packages\django\contrib\admin\templates\admin/login.html, error at line 4

Change History (8)

comment:1 Changed 9 years ago by adrian

  • Resolution set to invalid
  • Status changed from new to closed

Please use the ticket system for functionality improvements or bug reports -- not for tech-support.

comment:2 Changed 8 years ago by opera7@…

  • Component changed from Admin interface to Documentation
  • Keywords Template library django.templatetags.adminmedia added
  • milestone set to Version 1.0
  • priority changed from normal to high
  • Resolution invalid deleted
  • Severity changed from normal to critical
  • Status changed from closed to reopened
  • Version set to SVN

So, this bug in documentation?
PS. I've stumbled on this bug using Django r4218, win32, python 2.4.3, going through tutorial.

comment:3 Changed 8 years ago by adrian

  • Resolution set to invalid
  • Status changed from reopened to closed

Please ask tech-support questions on the django-users mailing list.

comment:4 Changed 8 years ago by anonymous

  • milestone Version 1.0 deleted

Milestone Version 1.0 deleted

comment:5 follow-up: Changed 6 years ago by bartosak

this is not a bug. You schould add thiese to your INSTALLED_APPS:

INSTALLED_APPS = (
    'django.contrib.auth',
    'django.contrib.contenttypes',
    'django.contrib.sessions',
    'django.contrib.sites',
    'django.contrib.admin',
}

comment:6 in reply to: ↑ 5 Changed 11 months ago by haroldo@…

  • Easy pickings unset
  • UI/UX unset

Replying to bartosak:

this is not a bug. You schould add thiese to your INSTALLED_APPS:

INSTALLED_APPS = (
    'django.contrib.auth',
    'django.contrib.contenttypes',
    'django.contrib.sessions',
    'django.contrib.sites',
    'django.contrib.admin',
}

I'm using django 1.6, and I'm having the same problem.
Here's my INSTALLED_APPS variable:

INSTALLED_APPS = (

'admin_tools',
'admin_tools.theming',
'admin_tools.menu',
'admin_tools.dashboard',
'django.contrib.admin',
'django.contrib.auth',
'django.contrib.contenttypes',
'django.contrib.sessions',
'django.contrib.messages',
'django.contrib.staticfiles',
'django.contrib.sites',
'south',
'servidor',
'agendador',

)

I got exactly the same applications you're citing, and the problem still occurs.
Has this been tested on django 1.6? Doesn't look like so. In fact, 'adminmedia' has been deprecated since 1.4, but you're still using it.
Are you really sure this isn't a bug?

comment:7 Changed 10 months ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to new

seconded

comment:8 Changed 10 months ago by claudep

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
Back to Top