Code

Opened 2 years ago

Closed 2 years ago

#18049 closed New feature (duplicate)

time lookup missng

Reported by: g00fy.box@… Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Normal Keywords: time lookup
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

there is day, month, year lookup ,but time lookup is missing

Example of use:

# lets search for events that start after 2 PM 
Event.objects.filter(start__time__gte=datetime.now())

SQL equivalent:

SELECT ... WHERE EXTRACT('time' FROM pub_date) >= '14:00:00';

Note:
Splitting datetime fields into two date & time fields sometimes makes no sense, and makes other stuff harder

Attachments (0)

Change History (1)

comment:1 Changed 2 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8424.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.