Code

Opened 2 years ago

Closed 2 years ago

#18047 closed Bug (fixed)

Reset password mail subject not internacionalizing as it should

Reported by: thiagocavila@… Owned by: nobody
Component: Internationalization Version: 1.4
Severity: Normal Keywords: django.contrib.auth.views
Cc: Triage Stage: Fixed on a branch
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description (last modified by claudep)

When I call for:

	url(r'^login/forgot/$', 'django.contrib.auth.views.password_reset', name='auth_forgot'),
	url(r'^login/forgot/done/$', 'django.contrib.auth.views.password_reset_done'),

Using default template and the generic views with no parameters.

It sends me and email with the body translated and the subject always in English.

Attachments (0)

Change History (3)

comment:1 Changed 2 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I forgot to say, I am using settings:
USE_I18N = True

And language: 'pt-br'

comment:2 Changed 2 years ago by claudep

  • Component changed from Uncategorized to Internationalization
  • Description modified (diff)
  • Type changed from Uncategorized to Bug

I was not able to reproduce your problem. Can you tell us the exact subject text that is produced? Can you check if your project does not provide its own /registration/password_reset_subject.txt

comment:3 Changed 2 years ago by thiagocavila@…

  • Resolution set to fixed
  • Status changed from new to closed
  • Triage Stage changed from Unreviewed to Fixed on a branch

I'm very sorry. I tried to detail how to reproduce the problem, then I updated Django to 1.4 final (I was using RC2). The problem was solved. Sorry for the inconvenience!

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.