Code

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#17849 closed Bug (duplicate)

testing framework fails when contrib.auth not in settings.

Reported by: on.celebi@… Owned by: nobody
Component: Testing framework Version: 1.3
Severity: Normal Keywords: auth_user test auth
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

This is the same issue than Ticket #14632, it still exists in Django 1.3.1.
This time, it's the contenttypes app which is causing the bug because of a dependency with auth.

Attachments (1)

django.txt (2.5 KB) - added by on.celebi@… 2 years ago.
Output

Download all attachments as: .zip

Change History (3)

Changed 2 years ago by on.celebi@…

Output

comment:1 Changed 2 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

So you are seeing 1.3.x and this was fixed in trunk afterwards the 1.3 release. Unfortunately, according to the backporting policy in effect, such fix isn't going to be ported to 1.3.x.

Duplicate of #14632.

comment:2 Changed 2 years ago by on.celebi@…

Sorry I wasn't clear. This is not the same issue, it has the same symptoms. This one is highly similar because with the same testcase (removing contrib.auth from INSTALLED_APPS) you obtain the same error output. But this time this is because of "contenttypes" app dependency to "auth" rather than "messages" 's one which was fixed for ticket #14632.

Maybe a better ticket would be "better dependency management between apps for the testing framework" instead of creating some tickets and fixes which just hide the error message?

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.