Code

Opened 2 years ago

Closed 13 months ago

#17818 closed New feature (duplicate)

Generic edit generic views don't create `fail_silently` success messages anymore.

Reported by: charettes Owned by: charettes
Component: Generic views Version: master
Severity: Normal Keywords: views generic edit messages
Cc: marc.tamlyn@…, hirokiky@… Triage Stage: Accepted
Has patch: yes Needs documentation: yes
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

It looks like the creation of success messages on valid form submission was oversight when the generic class based views were designed.

Here's a link to the django-developper discussion that motivated the creation of this ticket.

I'm also attaching a patch (with no tests and docs) that provide a simple yet overridable implementation that mimic the deprecated function based behaviour.

Attachments (2)

class-based-generic-edit-views-messages-v1.diff (4.6 KB) - added by charettes 2 years ago.
17818_test_v1.diff (10.2 KB) - added by hirokiky 14 months ago.
Tests for sending messages of edie views.

Download all attachments as: .zip

Change History (6)

Changed 2 years ago by charettes

comment:1 Changed 2 years ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted
  • Type changed from Uncategorized to New feature

comment:2 Changed 20 months ago by mjtamlyn

  • Cc marc.tamlyn@… added
  • Needs documentation set
  • Needs tests set
  • Version changed from 1.3 to master

I'm +1 on this feature being reintroduced, but -1 on it being on by default, especially as this would constitute a backwards incompatibility to me. We have views around which create messages similar to this, and turning it back on by default would mean duplicate messages, or messages where none were expected.

That said it's probably a useful feature by default, but I think there should be an upgrade path.

Changed 14 months ago by hirokiky

Tests for sending messages of edie views.

comment:3 Changed 14 months ago by hirokiky

  • Cc hirokiky@… added
  • Needs tests unset

I added a patch for testing this feature.

comment:4 Changed 13 months ago by charettes

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate of #16319.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.