Code

Opened 2 years ago

Closed 2 years ago

#17809 closed Bug (worksforme)

Admin static files not loading with dev server

Reported by: jrhorn424@… Owned by: nobody
Component: contrib.staticfiles Version: 1.4-beta-1
Severity: Normal Keywords: admin, staticfiles
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: yes

Description

Django version 1.4b1

I noticed that the "add" buttons inside model pages lacked the "plus" icon next to "add". Starting runserver_plus from django-extensions seems to indicate the problem might be with django.contrib.staticfiles.

Server log:

127.0.0.1 - - [01/Mar/2012 13:35:52] "GET /admin/survey/category/ HTTP/1.1" 200 -
127.0.0.1 - - [01/Mar/2012 13:35:52] "GET /admin/jsi18n/ HTTP/1.1" 200 -
127.0.0.1 - - [01/Mar/2012 13:35:53] "GET /static/admin/img/admin/nav-bg-reverse.gif HTTP/1.1" 404 -
127.0.0.1 - - [01/Mar/2012 13:35:53] "GET /static/admin/img/admin/tool-left.gif HTTP/1.1" 404 -
127.0.0.1 - - [01/Mar/2012 13:35:53] "GET /static/admin/img/admin/tooltag-add.gif HTTP/1.1" 404 -
127.0.0.1 - - [01/Mar/2012 13:35:53] "GET /static/admin/img/admin/default-bg.gif HTTP/1.1" 404 -
127.0.0.1 - - [01/Mar/2012 13:35:53] "GET /favicon.ico HTTP/1.1" 404 -

Relevant settings:

# Absolute path to the directory static files should be collected to.
# Don't put anything in this directory yourself; store your static files
# in apps' "static/" subdirectories and in STATICFILES_DIRS.
# Example: "/home/media/media.lawrence.com/static/"
STATIC_ROOT = os.path.join(PROJECT_ROOT, 'static')

# URL prefix for static files.
# Example: "http://media.lawrence.com/static/"
STATIC_URL = '/static/'

<snip>

STATICFILES_FINDERS = (
    'django.contrib.staticfiles.finders.FileSystemFinder',
    'django.contrib.staticfiles.finders.AppDirectoriesFinder',
)

Attachments (0)

Change History (1)

comment:1 Changed 2 years ago by jezdez

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this, but a bug was fixed in django-extensions a while ago: https://github.com/django-extensions/django-extensions/pull/124/files

You may have to upgrade django-extensions.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.