Opened 3 years ago

Closed 3 years ago

#17793 closed Bug (duplicate)

SimpleTepmlateResponse is not re-picklable

Reported by: ironfroggy Owned by: nobody
Component: Template system Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

When pickling a template response, a few attributes are stripped. Notably, template_name and context_data, from the state data for serialization. If you unpickle such a response and then try to pickle *that* object, setstate will fail when it tries to delete items from the data which are already missing.

1) Why are these removed and do they need to be?
2) If so, the del statements should catch KeyErrors or check for membership first.

Change History (1)

comment:1 Changed 3 years ago by carljm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report - duplicate of #16326 (which is, happily, already fixed in trunk).

Note: See TracTickets for help on using tickets.
Back to Top