Opened 3 years ago

Last modified 2 years ago

#17726 new Bug

Admin's Recent Actions broken for multiple admin site instances with unique registered models

Reported by: smacleod Owned by: nobody
Component: contrib.admin Version: 1.3
Severity: Normal Keywords: admin, multiple admin sites, recent actions
Cc: chipx86@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The Recent Actions list contains actions carried out from all admin site instances a user has access to. This causes problems when there exists a model which is not registered in all instances, and a User with access to multiple instances. If an action is carried out on this model it will appear in the recent list of all admin sites. If the model is not registered to an instance, the link generated will be invalid.

Ex:

  • AdminSite1 has model Model1 registered
  • AdminSite2 does not have Model1 registered
  • User has access to both admin sites
  • User adds a Model1 in AdminSite1 (Action1)
  • User visits AdminSite2, and clicks the Action1 link
  • User is directed to an invalid URL (url for Model1 in AdminSite2)

Change History (5)

comment:1 Changed 3 years ago by chipx86

  • Cc chipx86@… added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 3 years ago by aaugustin

  • Type changed from Uncategorized to Bug

comment:3 Changed 3 years ago by julien

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report, however this is a duplicate of #9151, which was wontfixed. If you disagree with this resolution, please take this question to django-developers.

comment:4 Changed 3 years ago by carljm

  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Triage Stage changed from Unreviewed to Accepted

I don't believe this is actually a duplicate of #9151, though it is similar. #9151 is about django.contrib.sites; this ticket is about creating multiple instances of django.contrib.admin.Site. Despite the confusing naming, those are two completely separate things. And I don't think the wontfix reasoning applied in #9151 applies here; while there may be nothing about django.contrib.sites.models.Site that warrants special treatment in the admin, I think it's reasonable to expect that the admin's *own* multiple-admin-site feature won't break the admin's own recent-actions feature.

Reopening.

comment:5 Changed 2 years ago by aaugustin

  • Status changed from reopened to new
Note: See TracTickets for help on using tickets.
Back to Top