Opened 3 years ago

Closed 3 years ago

#17714 closed Bug (wontfix)

Markdown filter does not support multiple configuration options for extensions

Reported by: scottie_000 Owned by: nobody
Component: contrib.markup Version: master
Severity: Normal Keywords: markup, markdown
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

Attempting to use a markdown extension with multiple options does not work. For example, using

{{ my_value|markdown:"safe,headerid(forceid=False,level=3),def_list" }}

within a template results in an exception with message

Extension "__builtin__.NoneType" must be of type: "markdown.Extension".

A patch for this is attached

Attachments (2)

17714_markdown_extensions_multiple_options.diff (1.6 KB) - added by scottie_000 3 years ago.
17714_markdown_extensions_multiple_options_with_tests.diff (3.5 KB) - added by scottie_000 3 years ago.
Updated original patch with Markdown extension tests

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by scottie_000

comment:1 Changed 3 years ago by lrekucki

  • Needs documentation unset
  • Needs tests set
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Regression tests are needed.

Changed 3 years ago by scottie_000

Updated original patch with Markdown extension tests

comment:2 Changed 3 years ago by scottie_000

I have added an updated patch to test markdown extensions.

I was not sure which markdown extensions, if any, were supported. However I have used def_list and headerid as a starting point.

comment:3 Changed 3 years ago by Fandekasp

  • Needs tests unset
  • Triage Stage changed from Accepted to Ready for checkin

Looks good to me

comment:4 Changed 3 years ago by timo

  • Resolution set to wontfix
  • Status changed from new to closed

Marking as won't fix since markup has been deprecated.

Note: See TracTickets for help on using tickets.
Back to Top