Opened 4 years ago

Closed 4 years ago

#17708 closed Bug (duplicate)

Django "sites" framework requires a Site model in every database during the tests.

Reported by: wojtekzozlak@… Owned by: nobody
Component: contrib.sites Version: 1.3
Severity: Normal Keywords: multiple databases sites tests
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


Lets assume, that we have two databeses - 'default' and 'main'.

We're using router, with defined allow_syncdb method, which distribute models between them.

We're also using a Django "sites" framework.

During the tests (./ test app), Django stubbornly tries to reach and populate the django_sites table in EVERY database, which of course ends with an error.

Change History (1)

comment:1 Changed 4 years ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #16828, #16515, #16353 and fixed in trunk and 1.3.X.

Note: See TracTickets for help on using tickets.
Back to Top