Opened 4 years ago

Closed 4 years ago

#17652 closed Bug (fixed)

LiveTestServer - we shouldn't advertise support for Windmill (or we should provide some docs)

Reported by: lukeplant Owned by: nobody
Component: Documentation Version: 1.3
Severity: Release blocker Keywords:
Cc: krzysiumed@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


After an hour or more of messing around, I really can't get anything helpful out of Windmill (at all, really, but especially in conjunction with Django in any kind of automated way)

The docs for it are pretty bad in terms of structure, so you can't just point people to the docs. (e.g: no proper tutorial, the nearest thing to a tutorial tells you to use IPython, but support for IPython > 0.10 is broken, etc etc.)

I've tried Windmill's own django support, which appears to be very broken, or extremely difficult.

So we shouldn't send people down the blind alley of using Windmill when we really don't support it at all.

Alternatively, if we can provide some documentation for how to use it - equivalent to the Selenium stuff - then we should. If the people who worked on this can comment that will help.

Change History (9)

comment:1 Changed 4 years ago by julien

  • Severity changed from Normal to Release blocker
  • Triage Stage changed from Unreviewed to Accepted

Thanks Luke for the report.

I'm the one who mentioned Windmill in the doc, mainly to replace the mention to Twill which itself appears to be a dead project. See the old doc:

However, I did not test the integration between Windwill and LiveServerTestCase and if it doesn't work then we should absolutely remove that mention from the doc. Therefore I'm marking this ticket as release blocker.

LiveServerTestCase was designed to be completely agnostic about what testing framework is used. So I tend to think that the issue lies in Windmill itself. Windmill is a fairly active project though, so it'd be nice if it did all work well (and if we could leave that mention in the doc). So I'll reach out to the Windmill maintainers to see if they have any thoughts on how to enable that support within their project.

comment:2 Changed 4 years ago by krzysiumed

  • Cc krzysiumed@… added

comment:3 Changed 4 years ago by julien

There hasn't been any code updates to the Windmill repository since April 2011 [1] or any blog/twitter updates for that project since November 2010. I've also tried to get some feedback on the #windmill channel on Freenode but no one's replied yet. I'll continue trying to get a hold of the Windmill guys.

In the meantime, if anyone is interested, you may also try using Splinter [2] instead as it's a much active project right now.



comment:4 Changed 4 years ago by julien

That said, I see that splinter is actually partially based on Selenium. So that might not really count ;)

comment:6 Changed 4 years ago by julien

Note: this gist contains an example with splinter:

comment:7 Changed 4 years ago by anonymous

After several attempts I still haven't got any reply in the #windmill Freenode channel. It seems like that project is in idle mode...

I'll remove all mentions to Windmill from the docs. Other projects such as Splinter or Ghost don't seem mature enough to guarantee a mention in our docs. They do seem to work with LiveServerTestCase though, so we could consider mentioning them in the future.

comment:8 Changed 4 years ago by julien

Oops, that was me. I'll push the doc fix in a minute.

comment:9 Changed 4 years ago by julien

  • Resolution set to fixed
  • Status changed from new to closed

In [17524]:

Fixed #17652 -- Removed all mentions to Windmill from the docs as that project doesn't integrate well with Django at this time.

Note: See TracTickets for help on using tickets.
Back to Top