Opened 3 years ago

Closed 2 years ago

#17599 closed Bug (duplicate)

Admindocs Example Misleading

Reported by: mlavin Owned by: nobody
Component: contrib.admindocs Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: yes
Easy pickings: no UI/UX: no

Description

https://docs.djangoproject.com/en/1.3/ref/contrib/admin/admindocs/#model-reference states shows an example of using the :model:`app_name.model_name` reference in the doc string of a Model. However, this does not create the hyperlink as indicated by the prior section. As you can see in the view the model's docstring is passed into the context without any addition parsing.

Attachments (1)

17599-draft.patch (2.0 KB) - added by aaugustin 3 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 3 years ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

I'm attaching a rough sketch of how we could improve the admindoc page for models.

Changed 3 years ago by aaugustin

comment:2 Changed 3 years ago by aaugustin

  • Has patch set
  • Patch needs improvement set

comment:3 Changed 3 years ago by anonymous

Still present in 1.4, the docs very clearly state this should work when it very clearly doesn't.

comment:4 Changed 3 years ago by RLion

Is this patch going to be included into any next releases ? I confirm the problem is still in 1.4

Another question is how can we help improving the patch ?

comment:5 Changed 2 years ago by Elvard

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ancient #5405.

Note: See TracTickets for help on using tickets.
Back to Top